BR100 Increased By (0.8%)
BR30 Increased By (1.35%)
KSE100 Increased By (0.88%)
KSE30 Increased By (0.73%)
AGHA 6.09 Increased By ▲ 0.01 (0.16%)
BECO 4.00 Increased By ▲ 0.04 (1.01%)
BML 62.31 Increased By ▲ 4.06 (6.97%)
BOP 27.51 Increased By ▲ 0.29 (1.07%)
CNERGY 12.72 Increased By ▲ 0.42 (3.41%)
CSIL 4.97 Decreased By ▼ -0.03 (-0.6%)
FCCL 52.62 Increased By ▲ 1.01 (1.96%)
FFL 12.97 Decreased By ▼ -0.11 (-0.84%)
FNEL 1.08 Increased By ▲ 0.02 (1.89%)
KEL 5.80 Increased By ▲ 0.15 (2.65%)
KOSM 5.18 Decreased By ▼ -0.03 (-0.58%)
LOTCHEM 22.93 Increased By ▲ 0.42 (1.87%)
MLCF 90.41 Increased By ▲ 1.58 (1.78%)
NBP 154.79 Increased By ▲ 3.71 (2.46%)
NCPL 52.53 Increased By ▲ 3.99 (8.22%)
NPL 55.97 Increased By ▲ 2.88 (5.42%)
OGDC 302.46 Increased By ▲ 1.54 (0.51%)
PACE 9.02 Decreased By ▼ -0.28 (-3.01%)
PAEL 32.75 Increased By ▲ 0.35 (1.08%)
PIBTL 13.21 Increased By ▲ 0.32 (2.48%)
PPL 215.27 Increased By ▲ 2.91 (1.37%)
PRL 96.09 Increased By ▲ 0.38 (0.4%)
PTC 42.46 Decreased By ▼ -1.84 (-4.15%)
SSGC 22.72 Increased By ▲ 0.19 (0.84%)
TBL 8.83 Decreased By ▼ -0.01 (-0.11%)
TELE 6.71 Increased By ▲ 0.16 (2.44%)
TPL 21.78 Increased By ▲ 0.37 (1.73%)
TPLP 11.52 Increased By ▲ 0.01 (0.09%)
TREET 22.61 Increased By ▲ 0.32 (1.44%)
TRG 54.71 Increased By ▲ 1.03 (1.92%)
Technology

Govt warns of critical WordPress flaws exposing websites to takeover

Published Updated

Pakistan’s National Cyber Emergency Response Team (National CERT) has issued a high-severity cybersecurity advisory, warning that actively exploited vulnerabilities in WordPress Core could allow hackers to seize complete control of websites without requiring any login credentials or user interaction, placing thousands of public-facing portals at immediate risk.

In its latest advisory, National CERT classified the threat as “critical”, citing widespread exploitation attempts and the public availability of proof-of-concept (PoC) exploit code.

The advisory warned that government portals, critical information infrastructure (CII), financial institutions, enterprise websites, and all organisations running vulnerable WordPress installations should treat the threat as an emergency and immediately deploy the latest security updates.

According to the advisory, attackers can exploit a chain of two critical vulnerabilities—identified as CVE-2026-63030 (wp2shell) and CVE-2026-60137—to remotely execute arbitrary code on targeted servers.

The primary flaw exploits confusion in the WordPress REST API batch-route endpoint (/wp-json/batch/v1) and combines it with a SQL injection vulnerability in the WP_Query class, enabling unauthenticated attackers to compromise websites and underlying servers.

READ MORE: Defence, banking and power systems: National CERT flags cyber threats

National CERT assigned a CVSS score of 9.8 to the remote code execution vulnerability and 9.1 to the SQL injection flaw, describing both as among the most severe categories of cyber vulnerabilities.

The advisory cautioned that successful exploitation could lead to complete website takeover, deployment of persistent web shells, theft of sensitive data, unauthorised modification or defacement of official portals, lateral movement across enterprise networks, disruption of digital public services, and serious reputational damage for affected organisations.

It further warned that exploitation activity began within hours of the vulnerabilities becoming public, underscoring the urgency of immediate defensive measures.

The advisory identified WordPress Core versions 7.0.0 through 7.0.1 and 6.9.0 through 6.9.4 as vulnerable to the remote code execution chain, while the SQL injection issue affects WordPress 6.8.x and later.

Organisations have been directed to immediately upgrade to WordPress 7.0.2, 6.9.5, or 6.8.6, depending on their deployment branch.

National CERT also advised organisations not to rely solely on automatic updates, warning that managed hosting environments may delay or block critical security patches. Administrators have been urged to manually verify the software version of every internet-facing WordPress installation.

For organisations unable to patch immediately, the advisory recommends blocking access to the vulnerable REST API batch endpoint through web application firewalls (WAFs), restricting unauthenticated API access, updating all plugins and themes during the same maintenance window, and validating WordPress core files against official release checksums to detect any tampering.

The cyber watchdog also instructed organisations to conduct comprehensive threat hunting by examining web server logs for suspicious requests targeting /wp-json/batch/v1, monitoring for unauthorised PHP files in writable directories such as /wp-content/uploads/, detecting abnormal process execution by web servers, and identifying unexpected outbound communications that could indicate command-and-control activity.

As part of its incident response guidance, National CERT directed all organisations to immediately audit public-facing WordPress instances, isolate compromised servers, preserve forensic evidence, rotate administrative credentials and database secrets after patching, and report confirmed incidents without delay.

The advisory concluded with an urgent call for organisations to strengthen continuous monitoring, deploy enhanced detection mechanisms, and report any suspected exploitation attempts or confirmed compromises to National CERT to help contain the rapidly evolving threat landscape.

Comments

200 characters remaining